Oracle Database 11gR2 install on OEL 6.5

73 yum install libaio

75 yum install libaio.i686

77 yum install glibc.i686

79 yum install compat-libstdc++-33.i686

81 yum install elfutils-libelf-devel

83 yum install libaio-devel.i686

85 yum install libgcc.i686

87 yum install compat-libstdc++-33.i686

89 yum install unixODBC.i686 unixODBC.x86_64

91 yum install unixODBC-devel.i686 unixODBC-devel.x86_64

93 yum install mksh.x86_64

 

Oracle Database 11g install on Centos 7

Problem encountered when installing Oracle 11g on Centos 7

Google suggested this was a fairly common problem with machines with a newer GLIBC. Most of the suggested solutions didn’t work for me (writing a glib memcpy shim etc). Instead I was able to statically link this executable against the glibc archive which didn’t have the problem with the missing [email protected] reference.

yum install glibc-static.x86_64

yum install glibc-static.i686

vi /u01/app/oracle/product/11.2.0/dbhome_2/ctx/lib/ins_ctx.mk

ctxhx: $(CTXHXOBJ)

-static $(LINK_CTXHX) $(CTXHXOBJ) $(INSO_LINK) /usr/lib64/stdc.a

I additionally had to patch the the ins_emagent.mk to link to the libnnz11 library:

vi /u01/app/oracle/product/11.2.0/dbhome_2/sysman/lib/ins_emagent.mk

Search for the line

$(MK_EMAGENT_NMECTL)

Change it to:

$(MK_EMAGENT_NMECTL) -lnnz11

Then press the Retry button and it should install correctly!

 

——

ALTER SYSTEM SET PROCESSES=500 SCOPE=SPFILE;

ALTER SYSTEM SET OPEN_CURSORS=500 SCOPE=SPFILE;

 

Fixing OVM 3.1.1 Database

I found myself in a situation where I had “ghost” repository servers in presented to my nfs repository. This stopped my from being able to import anything into the repository. Not good. So I found this quick fix….

 

Ran as follows:
/etc/init.d/ovmm stop

NOTE: cat /u01/app/oracle/ovm-manager-3/.config (This provides some of the info you need to connect to your db if you have forgotten.)

cd /u01/app/oracle/ovm-manager-3/bin/
./ovm_upgrade.sh –fixup –dbhost=localhost –dbport=1521 –dbsid=OVM –dbuser=ovs –dbpass=password

This ran fixed errors.

Restarted OVM Manager:
/etc/init.d/ovmm start